Summer Sale - Special 70% Discount Offer - Ends in 0d 00h 00m 00s - Coupon code: 70dumps

SPLK-1002 Questions and Answers

Question # 6

Which of the following commands will show the maximum bytes?

A.

sourcetype=access_* | maximum totals by bytes

B.

sourcetype=access_* | avg (bytes)

C.

sourcetype=access_* | stats max(bytes)

D.

sourcetype=access_* | max(bytes)

Full Access
Question # 7

Tags can reference which of the following knowledge objects?

A.

Lookups and event types only.

B.

Extracted fields, field aliases, calculated fields, lookups, and event types.

C.

Tags cannot reference any of these knowledge objects because tags are the last knowledge objects generated in the search-time operation sequence.

D.

Extracted fields, calculated fields, and field aliases only.

Full Access
Question # 8

In which of the following scenarios is an event type more effective than a saved search?

A.

When a search should always include the same time range.

B.

When a search needs to be added to other users' dashboards.

C.

When the search string needs to be used in future searches.

D.

When formatting needs to be included with the search string.

Full Access
Question # 9

When extracting fields, we may choose to use our own regular expressions

A.

True

B.

False

Full Access
Question # 10

How are event types different from saved reports?

A.

Event types cannot be used to organize data into categories.

B.

Event types include formatting of the search results.

C.

Event types can be shared with Splunk users and added to dashboards.

D.

Event types do not include a time range.

Full Access
Question # 11

A space is an implied _____ in a search string.

A.

OR

B.

AND

C.

()

D.

NOT

Full Access
Question # 12

The Field Extractor (FX) is used to extract a custom field. A report can be created using this custom field. The created report can then be shared with other people in the organization. If another person in the organization runs the shared report and no results are returned, why might this be? (select all that apply)

A.

Fast mode is enabled.

B.

The dashboard is private.

C.

The extraction is private-

D.

The person in the organization running the report does not have access to the index.

Full Access
Question # 13

Use the dedup command to _____.

A.

Rename a field in the index

B.

remove duplicate values

C.

provide an additional alias for the field that can D.be used in the search criteria

Full Access
Question # 14

When would a user select delimited field extractions using the Field Extractor (FX)?

A.

When a log file has values that are separated by the same character, for example, commas.

B.

When a log file contains empty lines or comments.

C.

With structured files such as JSON or XML.

D.

When the file has a header that might provide information about its structure or format.

Full Access
Question # 15

During the validation step of the Field Extractor workflow:

Select your answer.

A.

You can remove values that aren't a match for the field you want to define

B.

You can validate where the data originated from

C.

You cannot modify the field extraction

Full Access
Question # 16

The Splunk Common Information Model (CIM) is a collection of what type of knowledge object?

A.

KV Store

B.

Lookups

C.

Saved searches

D.

Data models

Full Access
Question # 17

In which Settings section are macros defined?

A.

Fields

B.

Tokens

C.

Advanced Search

D.

Searches, Reports, Alerts

Full Access
Question # 18

What will you learn from the results of the following search?

sourcetype=cisco_esa | transaction mid, dcid, icid | timechart avg(duration)

A.

The average time elapsed during each transaction for all transactions

B.

The average time for each event within each transaction

C.

The average time between each transaction

Full Access
Question # 19

Why would the transaction command be used instead of the stats command?

A.

The transaction command can perform calculations on fields.

B.

The transaction command is less resource-intensive.

C.

The transaction command keeps the raw data for each event.

D.

The transaction command has better search-time performance.

Full Access
Question # 20

Which search retrieves events with the event type web_errors?

A.

tag=web_errors

B.

eventtype=web_errors

C.

eventtype "web errors"

D.

eventtype (web_errors)

Full Access
Question # 21

What does the Splunk Common Information Model (CIM) add-on include? (select all that apply)

A.

Custom visualizations

B.

Pre-configured data models

C.

Fields and event category tags

D.

Automatic data model acceleration

Full Access
Question # 22

Which tool uses data models to generate reports and dashboard panels without using SPL?

A.

Visualization tab

B.

Pivot

C.

Datasets

D.

splunk CIM

Full Access
Question # 23

This function of the stats command allows you to identify the number of values a field has.

A.

max

B.

distinct_count

C.

fields

D.

count

Full Access
Question # 24

Consider the following search:

index=web sourcetype=access_corabined

The log shows several events that share the same jsesszonid value (SD462K101O2F267). View the events as a group.

From the following list, which search groups events by jSSESSIONID?

A.

index=web sourcetype=access_combined I transaction JSESSZONID I search SD462K101C2F267

B.

index=web sourcetype=access_combined SD462K101O2F267 | table JSESSIONID

C.

index=web sourcetype=access_combined | highlight JSESSIONID | search SD462K101O2F267

D.

index=web sourcetype=access_combined JSESSTONID < SD4€2K101O2F267 >

Full Access
Question # 25

In this search, __________ will appear on the y-axis. SEARCH: sourcetype=access_combined status!=200 | chart count over host

A.

status

B.

host

C.

count

Full Access
Question # 26

Which of the following fields should be normalized using the Splunk Common Information Model (CIM) based on their relationship?

A.

src_ip, dest_ip

B.

src_ip, source_ip

C.

index, sourcetype

D.

src_ip, src_port

Full Access
Question # 27

Which search would limit an "alert" tag to the "host" field?

A.

tag=alert

B.

host::tag::alert

C.

tag==alert

D.

tag::host=alert

Full Access
Question # 28

Which of the following statements describes POST workflow actions?

A.

Configuration of a POST workflow action includes choosing a sourcetype.

B.

POST workflow actions can be configured to send email to the URI location.

C.

By default, POST workflow action are shown in both the event and field menus.

D.

POST workflow actions can be configured to send POST arguments to the URI location.

Full Access
Question # 29

When using the timechart command, how can a user group the events into buckets based on time?

A.

Using the span argument.

B.

Using the duration argument.

C.

Using the interval argument.

D.

Adjusting the fieldformat options.

Full Access
Question # 30

To which of the following can a field alias be applied?

A.

Data found in a lookup table.

B.

Either a calculated field or an extracted field.

C.

Only one single field in a dataset.

D.

A given host, source, or sourcetype.

Full Access
Question # 31

Which of the following is NOT a stats function:

A.

sum

B.

addtotals

C.

count

D.

avg

Full Access
Question # 32

When using multiple expressions in a single eval command, which delimiter is used?

A.

, (comma)

B.

I (pipe)

C.

/ (forward slash)

D.

: (colon)

Full Access
Question # 33

The macro weekly_sales (2) contains the search string:

index=games | eval ProductSales = $Price$ * $AmountSold$

Which of the following will return results?

A.

‘weekly sales (3)’

B.

‘weekly_sales($3.995, $108)’

C.

'weekly_sales (3.99, 10)’

D.

‘weekly sales (3.99, 10)’

Full Access
Question # 34

A data model can consist of what three types of datasets?

A.

Pivot, searches, and events.

B.

Pivot, events, and transactions.

C.

Searches, transactions, and pivot.

D.

Events, searches, and transactions.

Full Access
Question # 35

Which of the following transforming commands can be used with transactions?

A.

chart, timechart, stats, eventstats

B.

chart, timechart, stats, diff

C.

chart, timeehart, datamodel, pivot

D.

chart, timecha:t, stats, pivot

Full Access
Question # 36

When used with the timechart command, which value of the limit argument returns all values?

A.

limit=*

B.

limit=all

C.

limit=none

D.

limit=0

Full Access
Question # 37

A field alias is created where field1—fieid2 and the Overwrite Field Values checkbox is selected.

What happens if an event only contains values for fieid1?

A.

field2 values are removed from the events.

B.

field1 and field2 values are merged.

C.

field2 values are unchanged.

D.

field2 values are replaced with the value of the field1.

Full Access
Question # 38

Which of the following file formats can be extracted using a delimiter field extraction?

A.

CSV

B.

PDF

C.

XML

D.

JSON

Full Access
Question # 39

Which of the following statements is true about the root dataset of a data model?

A.

It can contain transforming commands as long as it is a root search dataset.

B.

It will automatically contain knowledge objects associated with the base search.

C.

It must contain the transaction command if it is a root transaction dataset.

D.

It can only contain a base search with no transforming commands.

Full Access
Question # 40

Which group of users would most likely use pivots?

A.

Users

B.

Architects

C.

Administrators

D.

Knowledge Managers

Full Access
Question # 41

The limit attribute will___________.

A.

override default of 10

B.

only work with top command

C.

override default of 20

D.

override default of 15

Full Access
Question # 42

Which of the following is included with the Splunk Common Information Model (CIM) Add-on?

A.

Sourcetype definitions from the most popular technology vendors.

B.

A set of pre-configured data models.

C.

Scripted inputs to pre-align data with the CIM.

D.

Dashboards to validate data quality.

Full Access
Question # 43

Which knowledge object is used to normalize field names to comply with the Splunk Common Information Model (CIM)?

A.

Field alias

B.

Event types

C.

Search workflow action

D.

Tags

Full Access
Question # 44

Consider the following search:

index=web sourcetype=access_combined

The log shows several events that share the same JSESSIONID value (SD470K92802F117). View the events as a group.

From the following list, which search groups events by JSESSIONID?

A.

index=web sourcetype=access_combined | highlight JSESSIONID | search SD470K92802F117

B.

index=web sourcetype=access_combined | transaction JSESSIONID | search SD470K92802F117

C.

index=web sourcetype=access_combined SD470K92802F117 | table JSESSIONID

D.

index=web sourcetype=access_combined JSESSIONID < SD470K92802F117 >

Full Access
Question # 45

The gauge command:

A.

creates a single-value visualization

B.

allows you to set colored ranges for a single-value visualization

C.

creates a radial gauge visualization

Full Access
Question # 46

The eval command allows you to do which of the following? (Choose all that apply.)

A.

Format values

B.

Convert values

C.

Perform calculations

D.

Use conditional statements

Full Access
Question # 47

What functionality does the Splunk Common Information Model (CIM) rely on to normalize fields with different names?

A.

Macros.

B.

Field aliases.

C.

The rename command.

D.

CIM does not work with different names for the same field.

Full Access
Question # 48

Which of the following statements best describes the search string below?

| datamodel Application_State search

A.

Events will be returned from dataset Application_State.

B.

Events will be returned from the data model named Application_State.

C.

No events will be returned; the pipe must occur after the data model command.

D.

Events will be returned from the data model named Application_State (flat mode).

Full Access
Question # 49

Which syntax is used to represent an argument in a macro definition?

A.

"argument"

B.

%argument%

C.

‘argument’

D.

$argument$

Full Access
Question # 50

Which of these stats commands will show the total bytes for each unique combination of page and server?

A.

index=web | stats sum (bytes) BY page BY server

B.

index=web | stats sum (bytes) BY page server

C.

index=web | stats sum(bytes) BY page AND server

D.

index=web | stats sum(bytes) BY values (page) values (server)

Full Access
Question # 51

Which of the following statements describes Search workflow actions?

A.

By default. Search workflow actions will run as a real-time search.

B.

Search workflow actions can be configured as scheduled searches,

C.

The user can define the time range of the search when created the workflow action.

D.

Search workflow actions cannot be configured with a search string that includes the transaction command

Full Access
Question # 52

If there are fields in the data with values that are " " or empty but not null, which of the following would add a value?

A.

| eval notNULL = if(isnull (notNULL), “0” notNULL)

B.

| eval notNULL = if(isnull (notNULL), “0”

C.

| eval notNULL = “” | nullfill value=0 notNULL

D.

| eval notNULL = “” fillnull value=0 notNULL

Full Access
Question # 53

When using the Field Extractor (FX), which of the following delimiters will work? (select all that apply)

A.

Tabs

B.

Pipes

C.

Colons

D.

Spaces

Full Access
Question # 54

Splunk alerts can be based on search that run______. (Select all that apply.)

A.

in real-time

B.

on a regular schedule

C.

and have no matching events

Full Access
Question # 55

This is what Splunk uses to categorize the data that is being indexed.

A.

sourcetype

B.

index

C.

source

D.

host

Full Access
Question # 56

Using the Field Extractor (FX) tool, a value is highlighted to extract and give a name to a new field. Splunk has not successfully extracted that value from all appropriate events. What steps can be taken so Splunk successfully extracts the value from all appropriate events? (select all that apply)

A.

Select an additional sample event with the Field Extractor (FX) and highlight the missing value in the event.

B.

Re-ingest the data and attempt to extract from a new dataset.

C.

Click on the event where the field was not extracted and choose “Change to Delimited".

D.

Edit the regular expression manually.

Full Access
Question # 57

If a search returns ____________ it can be viewed as a chart.

A.

timestamps

B.

statistics

C.

events

D.

keywords

Full Access
Question # 58

What is the correct way to name a macro with two arguments?

A.

us_sales2

B.

us_sales(1,2)

C.

us_sale,2

D.

us_sales(2)

Full Access
Question # 59

Field aliases are used to __________ data

A.

clean

B.

transform

C.

calculate

D.

normalize

Full Access
Question # 60

After manually editing; a regular expression (regex), which of the following statements is true?

A.

Changes made manually can be reverted in the Field Extractor (FX) UI.

B.

It is no longer possible to edit the field extraction in the Field Extractor (FX) UI.

C.

It is not possible to manually edit a regular expression (regex) that was created using the Field Extractor (FX) UI.

D.

The Field Extractor (FX) UI keeps its own version of the field extraction in addition to the one that was manually edited.

Full Access
Question # 61

Which is not a comparison operator in Splunk

A.

< =

B.

=

C.

!=

D.

>

E.

?=

Full Access
Question # 62

When using the Field Extractor (FX) to perform a field extraction, which delimiter can be used?

A.

A period or comma.

B.

A comma.

C.

A tab or space.

D.

Any consistent character.

Full Access
Question # 63

Which of the following definitions describes a macro named "samplemacro" that accepts two arguments?

A.

Examplemacro [1,2]

B.

samplemacro(1,2)

C.

u amp -CJEUCXG (2)

D.

samplemacro[2]

Full Access
Question # 64

Which of the following statements about tags is true?

A.

Tags are case insensitive.

B.

Tags are created at index time.

C.

Tags can make your data more understandable.

D.

Tags are searched by using the syntax tag: : < fieldneme >

Full Access
Question # 65

When using a field value variable with a Workflow Action, which punctuation mark will escape the data

A.

*

B.

!

C.

^

D.

#

Full Access
Question # 66

Which of the following describes this search?

New Search

'third_party_outages(EMEA,-24h)'

A.

This search will find all events for the third_party_outages event type that have "EMEA" or "-24h" in the raw event data.

B.

This search will run the third_party_outages saved search and filter for events containing "EMEA" and "-24h" in the raw event data.

C.

This search will run the third_party_outages macro and pass the arguments EMEA and -24h to the macro definition.

D.

This search will find all events in the third_party_outages index with the tags EMEA and -24h.

Full Access
Question # 67

When using | timchart by host, which filed is representted in the x-axis?

A.

date

B.

host

C.

time

D.

-time

Full Access
Question # 68

Which of the following statements best describes a macro?

A.

A macro is a method of categorizing events based on a search.

B.

A macro is a way to associate an additional (new) name with an existing field name.

C.

A macro is a portion of a search that can be reused in multiple place

D.

A macro is a knowledge object that enables you to schedule searches for specific events.

Full Access
Question # 69

Which option of the transaction command would be used to specify the maximum time between events in a transaction?

A.

maxpause

B.

maxspan

C.

duration

D.

 eventcount

Full Access
Question # 70

In the Field Extractor Utility, this button will display events that do not contain extracted fields.

Select your answer.

A.

Selected-Fields

B.

Non-Matches

C.

Non-Extractions

D.

Matches

Full Access
Question # 71

Which of the following options should a user add to a search to limit transactions to a five minute time window?

A.

duration=5m

B.

bin=5m

C.

earliest=-5m

D.

maxspan=5m

Full Access
Question # 72

Which of the following objects can a calculated field use as a source?

A.

An alias of a field.

B.

A field added by an automatic lookup.

C.

The tag field.

D.

The eventtype field.

Full Access
Question # 73

Where are the results of eval commands stored?

A.

In a field.

B.

In an index.

C.

In a KV Store.

D.

In a database.

Full Access
Question # 74

Two separate results tables are being combined using the join command. The outer table has the following values:

The inner table has the following values:

Question # 74

The line of SPL used to join the tables is: join employeeNumber type=outer

How many rows are returned in the new table?

A.

Three

B.

Eight

C.

Five

D.

Zero

Full Access
Question # 75

Which of the following is included with the Common Information Model (CIM) add-on?

A.

Search macros

B.

Event category tags

C.

Workflow actions

D.

tsidx files

Full Access
Question # 76

These allow you to categorize events based on search terms.

Select your answer.

A.

Groups

B.

Event Types

C.

Macros

D.

Tags

Full Access
Question # 77

Based on the macro definition shown below, what is the correct way to execute the macro in a search string?

Question # 77

A.

Convert_sales (euro, €, 79)”

B.

Convert_sales (euro, €, .79)

C.

Convert_sales ($euro,$€$,s79$

D.

Convert_sales ($euro, $€$,S,79$)

Full Access
Question # 78

How can an existing accelerated data model be edited?

A.

An accelerated data model can be edited once its .tsidx file has expired.

B.

An accelerated data model can be edited from the Pivot tool.

C.

The data model must be de-accelerated before edits can be made to its structure.

D.

It cannot be edited. A new data model would need to be created.

Full Access
Question # 79

If a calculated field has the same name as an extracted field, what happens to the extracted field?

A.

The calculated field will override the extracted field.

B.

The calculated and extracted fields will be combined.

C.

The calculated field will duplicate the extracted field.

D.

An error will be returned and the search will fail.

Full Access
Question # 80

In what order arc the following knowledge objects/configurations applied?

A.

Field Aliases, Field Extractions, Lookups

B.

Field Extractions, Field Aliases, Lookups

C.

Field Extractions, Lookups, Field Aliases

D.

Lookups, Field Aliases, Field Extractions

Full Access
Question # 81

When is a GET workflow action needed?

A.

To send field values to an external resource.

B.

To retrieve information from an external resource.

C.

To use field values to perform a secondary search.

D.

To define how events flow from forwarders to indexes.

Full Access
Question # 82

A Splunk app is configured to extract domain names in web service logs and specify them as a field named domain.

What workflow action would return an external IP lookup for the field named domain?

A.

POST

B.

PUT

C.

GET

D.

Search

Full Access
Question # 83

In most large Splunk environments, what is the most efficient command that can be used to group events by fields/

A.

join

B.

stats

C.

streamstats

D.

transaction

Full Access
Question # 84

Which of the following can a field alias be applied to?

A.

Indexes

B.

Tags

C.

Event types

D.

Sourcetypes

Full Access
Question # 85

When can a pipe follow a macro?

A.

A pipe may always follow a macro.

B.

The current user must own the macro.

C.

The macro must be defined in the current app.

D.

Only when sharing is set to global for the macro.

Full Access
Question # 86

Which of the following commands connects an additional table of data directly to the right side of the existing table?

A.

subsearch

B.

update

C.

appendcols

D.

append

Full Access
Question # 87

What does the fillnull command do in this search?

index=main sourcetype=http:log | fillnull value="Unknown"

A.

Set the values of the field to null when it is "Unknown".

B.

Set all fields that are null to "Unknown".

C.

Set the values of the field to "Unknown" if it is null.

D.

Set all fields with the value of "Unknown" to null.

Full Access
Question # 88

What does the fillnull command replace null values with, if the value argument is not specified?

A.

0

B.

N/A

C.

NaN

D.

NULL

Full Access
Question # 89

In the following eval statement, what is the value of description if the status is 503? index=main | eval description=case(status==200, "OK", status==404, "Not found", status==500, "Internal Server Error")

A.

The description field would contain no value.

B.

The description field would contain the value 0.

C.

The description field would contain the value "Internal Server Error".

D.

This statement would produce an error in Splunk because it is incomplete.

Full Access
Question # 90

Information needed to create a GET workflow action includes which of the following? (select all that apply.)

A.

A name of the workflow action

B.

A URI where the user will be directed at search time.

C.

A label that will appear in the Event Action menu at search time.

D.

A name for the URI where the user will be directed at search time.

Full Access
Question # 91

A user runs the following search:

index—X sourcetype=Y I chart count (domain) as count, sum (price) as sum by product, action usenull=f useother—f

Which of the following table headers match the order this command creates?

A.

The chart command does not allow for multiple statistical functions.

B.

Product, sum: addtocart, sum: remove, sum: purchase, count: addtocart, count: remove, count: purchase

C.

Product, count: addtocart, count: remove, count: purchase, sum: addtocart, sum: remove, sum: purchase

D.

Count: product, sum: product, count: action, sum: action

Full Access
Question # 92

When a search returns __________, you can view the results as a list.

A.

a list of events

B.

transactions

C.

statistical values

Full Access
Question # 93

Given the following eval statement:

... | eval field1 = if(isnotnull(field1),field1,0), field2 = if(isnull(field2), "NO-VALUE", field2)

Which of the following is the equivalent using fillnull?

A.

... | fillnull values=(0,"NO-VALUE") fields=(field1,field2)

B.

There is no equivalent expression using fillnull

C.

... | fillnull field1 | fillnull value="NO-VALUE" field2

D.

... | fillnull value=0 field1 | fillnull field2

Full Access